.net, Asp.net, IIS, Tips

aspnet_wp.exe could not be launched because the username and/or password supplied in the processModel section of the config file are invalid.

I was running a WinXP box and all of a sudden I started getting a “Server Unavailable” error. I know for a fact that it had to do with the ASPNET account. So here’s what I did that did not help:

1. Give ASPNET account full control over your home directory
2. Delete ASPNET account and ran aspnet_regiis -i
3. Google for the error got me to this link KB315158.

Extract from the article:

RESOLUTION

To work around this problem, use one of the following methods:
•Create a weak account that has the correct permissions, and then configure the <processModel> section of the Machine.config file to use that account.
•Set the userName attribute to SYSTEM in the <processModel> section of the Machine.config file.
•Configure the <processModel> section of the Machine.config file to use an administrator account.

I chose to proceed with option 2. I opened up Machine.Config located in

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\config\machine.config

And modified the following line:

FROM: <processModel autoConfig=”true”/>

TO: <processModel userName=”SYSTEM”/>

I tried accessing the website and still the same error. Well, the one thing that was missing in the article is that the processModel section will only be called when IIS starts. So I did a

Start -> Run -> IISRESET

I tried accessing the website and it started working. I was a little worried about using the SYSTEM account so I went back to the machine.config, reverted the changes I made (set processmodel back to autoconfig) and restarted IIS. Well the site still works.Its crazy… I am not sure as to what happened, but If someone knows why this worked please let me know in the comments!

Advertisements

32 thoughts on “aspnet_wp.exe could not be launched because the username and/or password supplied in the processModel section of the config file are invalid.

  1. Crazy indeed! After 3 days of surfing and trying out all the complicated solutions from all over…only the simplest solution suggested above worked for me. My station uses XP & IIS 5.1. Right now, I’m resuming search for solution for IIS 6.0 for our Winserver 2003.

  2. Thank you so much for posting this solution!!!

    After banging my head on the wall for 2 hours, finally found something that works. I don’t have any idea why this worked but I am glad it worked.

  3. Thank you so much. I have searched and searched for a solution and I finally found one on your site. I have configured windows server 2003 with iis/asp.net numerous times and I’ve never had this issue. But configuring IIS/ASP.net on Windows XP is a different ballgame. Thanks for your help!

  4. Your solution fixed my issue, i almost spent my whole day to fix this issue, and finaly yours worked. however, it did not work after changing the machin.config, it says the password is not … be aware of case sensitivity, etc.
    But did not get the server not available error though. So i simply changed the password to

    From the recently changed : one. and it all worked fine, Awsome, we all love you Balaji.

    Cheers,

  5. I still cant bellieve that this was actually solution. I have spent more than 5 hours in every single solution that I have found on internet. I have on machine installed XP SP3, Net Framework 2.0, 3.5 SP1, VS 2005, VS 2008.

  6. It was temporary solution.
    The problem still persist.
    And to be worse, there is no rule on his behavoir.
    Somethimes is everythig fine, and sometimes not.

  7. In my case, this solution didn’t work. It was a long story..let me be brief. I had VS 2008 already installed on my Windows XP machine. But the code I had to work on was in VS 2003 (.Net framework 1.1). So I installed V 2003 on top of VS 2008. When I ran the web app on VS 2003, I got the error. I tried everything, including the suggestion given in this blog, but none worked.

    After scratching my head I found that the ASPNET account (fullname ASP.NET Machine Account) was missing. You could see this by going Control Panel – Admin tools – Comp mgmnt – Local Users And Groups – Users. VS 2008 doesn’t need this, but VS 2003 needs it. Some how the preexisting VS 2008 was preventing VS 2003 to create this account. So I uninstalled VS2008 and 2003 and also all the .Net framewors (1.1, 2.0, 3.0 and 3.5) and reinstalled VS 2003 and VS 2003 SP1. After this the website has started working. I spent one whole day to figure this out. Hope someone benefits from this post.

    Thanks

  8. GREAT!!!!
    I use vista and no practice with XP, so I lost hours helping my friend to install IIS and ASP.NET until I found your clear indication!
    Thanks!

  9. Thank you very much, this helped me!
    I’ve wasted all of yesterday trying to get a asp.net website to work on a xp-machine. Manipulating the Machine.config file, reinstalling .net framework and iis in different order, browsed numerous kb’s, all to no avail, until i came over your blog and the tip about restarting IIS.

  10. Not sure about back when you first had this problem, but now, attributes names are case sensitive and username needs to be “userName” with a capital N.

  11. Thanks for this, it worked for me! Switching it back did not, so I’m leaving it set to System. (I’m on a dev machine) Also the “userName” attribute is case sensitive (capital ‘N’), that gave me some fits.

  12. Windows XP Users: You can try this option. Please check the properties of ASPNET user. I might have been locked out. You can unlock it as follows.
    Start->My Computer – right click ->Click Manage
    Select Local Users Groups ->Users
    Right click on ASP.NET user name-> Properties
    See if Account is locked out check box is checked, please uncheck it and restart IIS. Goodluck.

  13. Thank you very much for this post. Thank you Balaji Ramesh and John Velu. You ‘ve just saved me. It took me one day on this issue. Wish you have more useful post.

  14. Was about to start going through the Balaji’s exercise BUT, thanks to Sriram’s post, I found that the ASPNET user was locked out. I unlocked it following the directions from Sriram’s post and it works. Spent all morning on this before finding this solution… Thanks guys.

  15. This worked for me too but I wasted 3 days on this issue. I’m not sure what happened, although typical of me to mess things up. Thanks a bunch.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s